Yoyofactory Velocity Dial not clicking or staying in place


#1

Hey I’m new to yoyo and brought the Velocity to learn on. I took the thing apart out of curiosity and removed those white plastic response pads by turning the dial to pro and they just came out. But when I put them back they won’t click when I turn the dial and they seem loose and doesn’t stay in place.

I’ve tried screwing them back, snapping them down and tried lining the 3 dial holes too.

Is there anyone who owns the Velocity that knows how to put them back correctly?

****Update

I found 2 hidden screws behind both logo stickers which lets you open up the dial.

Inside under the dial piece there is a metal washer that’s bent to act as a spring… Bending the washer a bit more increased the spring and kinda fixed the problem.


#2

Hmm, the shuttles should come out when you turn to “easy” not “pro”. “Pro“ recesses them into the yoyo- screws them into the yoyo away from the string to make the yoyo less responsive. "Easy pushes them out of the yoyo halves, toward the string to make the yoyo more responsive, comes back with an easy tug.

Try turning the dial all the way to easy, and then back towards pro a bit. Then you should be able to snap the shuttles back in, and turn the dial toward easy to pull the shuttles back into position. Make sure when you snap them in, that you get each prong to snap in the same amount.

GL!


#3

Whoops sorry I said it backwards.

I can get them back inside or snap them but the problem is that it doesn’t have that rough click turn feel when adjusting as when I first tried it before taking it apart.

It feels like it lost a lot of resistant to turn and the string moves the thing when trying to yoyo a bit so it doesn’t stay that well. I can also push the thing down with a bit of touch even when it’s screwed in a bit.