Unresponsive turned responsive and axle is stuck

Today I was practicing 5A with my Duncan Counterpunch when I had accidentally dropped it, afterwards I was practicing ghost bind when it came back up and it continues to play responsive. Can anybody help and thank you in advance

Hi Sebastian,

Please check the bearing if it’s clean, it can easily absorb dusts. It’s funny to think, but there are times where I dropped my yo-yo on the ground - I can see a piece of hair wrapped around the bearing.

1 Like

It’s clean

Does the bearing spin freely when you flick it with your finger? Did a response pad break loose?

Maybe if you give the bearing a quick clean, and tit y again?

Check that the bearing seat didn’t get damaged or that the axle didn’t get bent when you dropped it.

I tried to use a new axle but now the axle is stuck into the yoyo and I cant get it out

So did you use the correct screw threads in the new axle? Since it is now stuck I would use a pliers to carefully unscrew it so as not to screw the threads up more than they are.

I tried to use pliers and no use

The axle is completely stuck and Ive tried everything