Responsive Sasquatch (PLEASE HELP!)


(Halbach) #1

Okay, I’ve never faced a problem like this.

My sasquatch has been unresponsive up until now. I thought the bearing just needed a cleaning. Cleaned it. Responsive. Cleaned it again. Responsive. Cleaned again. Responsive

I need help. I’ve never had it do this, and I don’t want to lose an amazing yoyo.

What should I do?


#2

Features a nice wide gap with a Size C (.250 x .500 x .187) bearing. Note: the Raptor is semi-responsive out of the package. For complete unresponsiveness YoYoExpert recommends purchasing a clean bearing to replace the stock bearing with. It will also break in and become less responsive with general play.


#3

same thing happened to me but my xodus 2 bearing so i play it till it get unresponsive and spins more cuz it also when i cleaned it didn’t spin as good as before :-\


(Halbach) #4

We’re talking about the Sasquatch. The bearing has been cleaned 4 times.

And, for an update, I’ve tried 3 bearings. All w/ the same result. Responsive.


#5

Probably you need to break the silicone in, also check if it is flush


(Halbach) #6

It was broken in. It didn’t become responsive up until an hour ago. It’s been dead unresponsive before that.


#7

Just make sure that there is nothing in the bearing seat.

Also, if the bearing seat is cleaned, just keep playing with the yoyo.

Don’t worry if it’s responsive, it’ll make you more manly.


(Halbach) #8

I can’t play responsive. I’ve been working on a new trick that involves too much movement for the responsive feel. I

On a note, I found what looked like candle wax in the bearing seat, but, even after removing it and putting in a different bearing, it was STILL responsive. FML.


(Q) #9

Step one: remove bearing.
Step two: obtain a Q-tip ( any jokes about this in reference to my name will result in me finding you. Like, seriously. I will find you, and cut you.)
Step three: dip q-tip in your favor solvent. IE: Lighter fluid, mineral spirits.
Step four: go at the bearing seat with said solvent covered q-tip
Step five. Follow up your job with a tooth pick.


(Halbach) #10

Sounds good. Will do :slight_smile:


(Halbach) #11

Did not help.

Why does this kind of stuff happen to me?


(Q) #12

How thorough were you with the cleaning?


(Halbach) #13

Pretty darn thorough.

the thing that gets me is that it was working fine, and just all of a sudden became responsive.

I’m thinking the best thing to do would be send it back to YYE for another one. It would save me alot of trouble.


#14

Just keep playing with it. Lol


(Halbach) #15

Tried that. Alot.


(Q) #16

Unless it is a manufacturers defect, the problem has to be able to be fixed.

You’ve cleaned both halves and allowed them to dry? Leave the bearing out of it and in a cleaning solution over night. Leave the halves idol all night after you clean the bearing seats again. If that doesn’t work, go ahead and contact YYE.


(Halbach) #17

I guess I’ll try this.


(Kyle V.) #18

DG, I had this same problem with my SPYY Pro. It was DEAD unresponsive when I got it, and shortly after that it became impossibly responsive. I was pretty bummed, but I continued to use it. After quite a while, probably weeks, it finally just lost all responsiveness again and it’s been fine ever since. No idea why this kind of thing happens, but it does happen. I feel your irritation.


(Halbach) #19

Thanks so much. Sounds just like what’s happening w/ mine, I’ll just keep playing and hope for the best :slight_smile:


#20

And this has what to do with the topic at hand??