Possible M1 Problem


(Infinite Chaos) #1

Recently got my M1s and I’ve taken the bearing apart, cleaned them and re-shielded and everything. Still responsive though. Any suggestions? ??? I really dislike responsive play. :stuck_out_tongue:


#2

Responsive play does wonders, but if you lube it then it’ll take time to break in. Just play with it.


(Infinite Chaos) #3

Whatcha mean? Maybe this is something that I’m missing out on then?


#4

Well it helps to smooth out your play. If you only play unresponsive, you could mess up and not have anything happen from it. If you play responsive for a while, it just does wonders. You’ll find out what I’m talking about after you do it.


(Infinite Chaos) #5

Alright, I’ll try this then, see how it goes. thanks! :smiley:


#6

You have to dry completely, and then give it some play before it is unresponsive. If there is any solvent in there at all, it will stay responsive. :wink:


#7

Just play with the yoyo for about a week, and break the bearing in,


#8

Pads? or Flow Groove?

Both take time to wear in and can be grippy at first.


#9

I got an M1 recently for 45 dollars and i just kept on binding over and over again and it got unresponsive over time. Now if I tug it up it won`t come up so yeah you can do that or the other things that they sai try them.


#10

you need to break it in may take some time


#11

I’m pretty sure that’s what we’ve said.


(Infinite Chaos) #12

pads.


(YoYoBlaze) #13

another thing ED HAPONIC


(Mikey) #14

My bro’s pads were responsive at first, After time and A tiny bit of lube, it was less responsive.