Bearing Problem


#1

I don’ know,but my Axiom just became responsive,I cleaned the bearing seat,but still no help,so i checked the bearing,it was clean,nothing inside it.What could be the problem?

Extra Details:

1:I dropped the bearing a couple times
2:I am using a dry bearing


#2

Dry bearing is responsive? Put a drop of oil in there and break it in.


#3

So dropping the bearing does no harm?


#4

Not unless you drop it in a pool of magma or a pile of poo. (Or some other things, but you get the idea…)


#5

Things I missed out:
I just siliconed the yoyo
The bearing used to be unresponsive

Okays…so i should drop a bit of lube and break it in?


#6

A little lube always helps. Also make sure there’s no sili in the bearing seat etc.


#7

Yeah,I cleaned it,that is definitely not the problem


#8

Well, make sure there’s nothing in the bearing seat as well.


#9

Wasn’t that what jhb just said?
I have to go to sleep now,will put some lube into the bearing.

Until then


(Cinimod105) #10

Wait, some silicone could have gotten into the bearing. Try cleaning the bearing again. The last time I siliconed my yoyo, my bearing suddenly went silent and responsive, and after I cleaned it, it worked fine. So I presume that some tiny bits of silicone went into the bearing.


#11

Alright,I did what I had to do,and it became unresponsive again.Thanks everyone.

Topic closed