Trigger help


#1

Hey guys,

I just got the trigger in the mail and I totally love it.  The hour is great as well.  But upon getting my first not in my trigger I discovered that it does not unscrew.  Is this normal?  And if it is, how do I get rid of nots?

#2

Keep on turning it’ll unscrew eventually


#3

Was yours hard to unscrew?


#4

Been working on it for about a half hour. Hasn’t budged.


#5

Can I return a yoyo and get a new on if it has a defect?


#6

Sorry about the triple post. But can can you please help?


#7

Hmm, nothing’s wrong with mine.

Are you sure that you are twisting the correct way?


#8

Yeah. I am going to the left with the top.


#9

Hmm, sort of weird that it’s not unscrewing. Mine unscrews perfectly.

You should probably contact the store where you got it. :slight_smile:


#10

I got it from yye. I tried putting a towel over it and using pliers but they were to small.


#11

Find a big person? Or just get a knot puller and remove it without disassembly.


#12

I was gonna try to saw the thing in half and get a new axle. What is a not puller.


(Waylon) #13

Don’t do anything drastic. Just email YYE. In the meantime, enjoy your Hour :slight_smile:


#14

Okay. What is the email address? And I totally love my hour so that shouldn’t be that hard.


#15

I use small zip ties to pull out knots. Plastic coated paper clips work well. Certain pen caps.


(Waylon) #16

Contacting YoYoExpert:

We know you have lots of questions and we want to get you an answer fast so please feel free to contact us anytime:

By Email: Contact@YoYoExpert.com

By Phone: USA: (413) 551-9696

By Mail:


PO Box 2276
Amherst, MA 01004-2276


#17

VICTORY!!! I emailed yye and told them my problem and they told me to use some gloves and it totally worked. Thanks for all the advice.


(Waylon) #18

:slight_smile: