Problem with duncan torque


#1

So yesterday, i try to put the sky hawk’s rings into the torque. Now, they stuck there and i can’t take these rongs out. Can you help me


#2

The rings can be very hard to remove without damaging the yo-yo (or the rings). Try prying them out with the handle of a wooden spoon or something similar. Something that won’t scratch the metal, but is still solid enough to pry out the rings.


#3

Do not actually do this

When I had an axel that I couldn’t get out of a yoyo, I was told by a teacher just to melt the whole yoyo into a little puddle of metal, then I could get the axel out. So if you melt the yoyo down you can get the rings right on out no problem! :wink:


#4

I had Freehand Zero with old weight rings in it. I tried for a long time to get them out, and then I tried a Gerber Shard to pry it out and they popped right off. I have no idea if it have one of those but I think any kind of angled prybar would work the same way. I hope that helps


#5

To be honest, i have tried to use a compass, a pen, a pencil and they just broke :’(


#6

Try something sturdier. Wooden spoon with a thick handle always works for me. I’ve also used a set of pliers with a rubberized handle in the past.


#7

I just use the pliers