PLEASE HELP!!!!!!!!!!!


#1

I have been throwing my y factor for a bout a week and a half. The bearing is messed up and i desperetly need to clean it and lube it. I have the supplies for cleaning but i dont know what to use for lube?


#2

just clean it, you don’t need to lube it, i’m running a bearing dry right now, and it works fine
just remember to completly dry it off when your done cleaning. use a hair blower or something


#3

Ok thanks whole bunch. Doing it right now. ;D


#4

I cleaned it and didint lube it and dried it and everything u said. It played great for half an hour and then it went back to the same thing. I have no idea what to do. :’( :’( :’( :’( :’( :’( :’( :’( :’( :’( :’( :’(


#5

did you recently silicone it?

is the bearing seat messed up?

are you dropping the bearing alot?


#6

What’s happening? Responsive?


#7

I havent been doing anything else than yoyoing with it. The bearing has very much vibe is responsive. I have not siliconed it and nothing is wrong with the bearing seat and i havent dropped it once. Im pretty sure its the bearing bcuz when i flick it it sounds horrible and vibrates


#8

the bearing doesnt have vibe. thats nonsensical. maybe the YOYO has vibe. i think you may mean rattles. clean it again. then lube it. does the bearing sound “grindy” then you move it along with your fingers? (NOT flick spin)


#9

Clean your bearing. Lube after the problem is solved if you want it at all.


#10

The bearing could just be breaking in you know.


#11

Not if the bearing vibrates with a crackle.


#12

try taking off the shields, do you know how to do that?


#13

Ha, ^^, just to add to ^^ post, if you clean the bearing with shields on, it’s almost useless.


#14

just a little side note, i have had bearings that have caused vibe in a yoyo. it is not nonsensical, it has actually hapened to me before when i was at moyo.


#15

Buy a new bearing :DD