lunatic-axel problems.:(


#1

just the other day i was doing some rim polishing on my 888x and my lunatic.after i finished my lunatic,when i tried to screw it together it dosent tighten.it just keeps screwing,and screwing,and screwing.i figured it was just a striped axel.so i tried other axels to see if they would screw in.they screw in but are either too long,or too short.so basicaly,the point of this thread is how do i fix this problem as soon as i can,do i need a new axel,or could i use lock-tight.thank you for your time.yo-bear


#2

Well it sounds like you stripped the yoyo not the axle. Does the axle have threads on it still? Or id it turn silver with what looks like aluminum clogging up the threads?

A fix will be sending it to a modder to be rethreaded to a nother axle size.

Also wrong section. This goess in the mod and maintenance section. MOVED.


#3

sorry bout that.so,does this mean my yoyo is done for?


#4

Can you post some pics?


#5

Post some pictures of the half and the axle. Use the macro setting on your camera so you can get really close. Also I don’t think your yoyo is done for. It may just need some help coming back to life. Or I can trade you a working yoyo for it.