Internet woes: Help with Default Gateway Needed!


#1

So today, I attempted to set a static IP, and it’s now recognized as static, but my Default Gateway has changed to 0.0.0.0. In addition, when I used the ipconfig command, it says I’m in a media disconnected state. So now, I can’t connect to the Internet from the PC because of this.

Any advice? This PC runs on Vista, and is connected with Ethernet. I disconnected the Ethernet cable from both the PC and Modem/Router thing, but that didn’t help. Also note that DHCP is off. Should this be on? I was attempting to set up a static IP to forward ports. Any help is greatly appreciated.


#2

Were you given an IP by your ISP to use as a static IP or is this just between you and your router? Setting the static IP on the PC turned off the DHCP on the PC. Your router is probably still doing DHCP. Your router needs DHCP outgoing unless your ISP gave you a static address. You can set static addresses internally but you need to coordinate your devices w/your router. Also use something in the range of 192.168.x.x for internal addresses. Your gateway address should be your router.


#3

No, I didn’t use an IP given from my ISP. I followed what a few guides said, and found the range of IP’s on my modem, and set the static IP outside of that so it wouldn’t assign other devices that address. I followed the 192.168.x.x format, and I put the gateway as the router, but somehow, it changed to 0.0.0.0, and became media disconnected.

So even if I’m using a Static IP, one that’s not from my ISP, should I turn on the DHCP to outgoing, or should that be off for all static IP’s? (I’m assuming the latter?)

Edit: Within the past few hours, I haven’t touched the computer, yet the IP has changed and become dynamic. At this point, I don’t really care if I get it to Static, I just want to be able to connect to the Internet. I’m probably getting a new ISP soon anyways.

The machine has given me the option of “Automatically get new IP settings”. Should I use this? Will the Gateway change back from 0.0.0.0 to its original #?


#4

I have a static IP since I run my web server and mail server hosted from my location.

What you need to do is use a broadband router of some sort. Assign the assigned IP address to the WAN/internet port. This may happen via DHCP if the Radius server assigns that information out upon a successful authentication. Most do, because honestly it makes life easier from an administative point of view.

Behind the router, you can use DHCP, provided that your router is functioning as a DHCP server. I don’t use my router as a DHCP server since I am doing reservations and more information than the routers provide.

You can be dynamic behind your router/firewall. That’s fine. Unless something needs to reach an internal resource on your network from the outside(such as a web server or email server), those machines need to be at a fixed(static) non-routeable address on your network, and then you have to direct the appropriate ports to your machines.

When you have been given an address, when you do:
ipconfig /all
(go to Start: Run, type “cmd” to get the command prompt window first)
you’ll see if DHCP is on/offand if you’ve been assigned an address.

Without knowing your entire situation, I can’t advise further. Call me if you need more help. Be prepared to be very detailed and break down every little detail if you do so. I’m quite thorough.

In the meantime, enable DHCP.


(WildCat23) #5

It’s because you run Vista.


#6

It has nothing to do with Vista.

Double check your Internet settings with your isp provider as jhb8426 suggested. You can’t configure a static ip unless you’re assigned one by the provider.

If you just want to go back to ‘normal’, it might be easiest to factory reset your router and just rerun the setup wizard.


(WildCat23) #7

I know, your sarcasm detector must be broken.

Seriously though, Vista is terrible.


#8

Yes, Vista is pretty bad. I much prefer Windows 7,which I have on my Gaming PC. Thanks for all the advice guys, I’ll attempt to use it to fix the thing tomorrow.